<!DOCTYPE html>
<!--[if IE 6]><html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns# video: http://ogp.me/ns/video# ya: http://webmaster.yandex.ru/vocabularies/"><![endif]--><!--[if IE 7]><html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns# video: http://ogp.me/ns/video# ya: http://webmaster.yandex.ru/vocabularies/"><![endif]--><!--[if IE 8]><html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns# video: http://ogp.me/ns/video# ya: http://webmaster.yandex.ru/vocabularies/"><![endif]--><!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!--><html lang="fr-FR"><!--<![endif]--><head><meta charset="UTF-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="pingback" href="https://www.skyminds.net/xmlrpc.php"><title>MariaDB : r&eacute;soudre l'erreur 1062 avec la r&eacute;plication des bases de donn&eacute;es</title><style rel="abtf" id="AbtfCSS">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</style><meta name="description" content="Guide pour r&eacute;soudre l'erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es avec MySQL ou MariaDB."><meta name="robots" content="noodp"><link rel="canonical" href="https://www.skyminds.net/mariadb-1062-duplicate-entry-replication/"><link rel="publisher" href="https://www.google.com/+SkymindsNet"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="MariaDB : r&eacute;soudre l'erreur 1062 avec la r&eacute;plication des bases de donn&eacute;es"><meta property="og:description" content="Guide pour r&eacute;soudre l'erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es avec MySQL ou MariaDB."><meta property="og:url" content="https://www.skyminds.net/mariadb-1062-duplicate-entry-replication/"><meta property="og:site_name" content="SkyMinds.Net"><meta property="article:publisher" content="https://www.facebook.com/skyminds"><meta property="article:author" content="https://www.facebook.com/skyminds"><meta property="article:tag" content="base de donn&eacute;es"><meta property="article:tag" content="MariaDB"><meta property="article:tag" content="r&eacute;plication"><meta property="article:tag" content="root"><meta property="article:tag" content="terminal"><meta property="article:tag" content="tuto"><meta property="article:tag" content="VPS"><meta property="article:section" content="Web/Tech"><meta property="article:published_time" content="2017-07-07T11:47:03+02:00"><meta property="og:image" content="https://static.skyminds.net/mariadb-replication-and-ha.png"><meta property="og:image:width" content="1200"><meta property="og:image:height" content="407"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:description" content="Guide pour r&eacute;soudre l'erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es avec MySQL ou MariaDB."><meta name="twitter:title" content="MariaDB : r&eacute;soudre l'erreur 1062 avec la r&eacute;plication des bases de donn&eacute;es"><meta name="twitter:site" content="@skyminds"><meta name="twitter:image" content="https://static.skyminds.net/mariadb-replication-and-ha.png"><meta name="twitter:creator" content="@skyminds"><meta property="DC.date.issued" content="2017-07-07T11:47:03+02:00"><link rel="dns-prefetch" href="//www.skyminds.net"><link rel="dns-prefetch" href="//s0.wp.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="alternate" type="application/rss+xml" title="SkyMinds.Net &raquo; Feed" href="https://www.skyminds.net/feed/"><link rel="alternate" type="application/rss+xml" title="SkyMinds.Net &raquo; Comments Feed" href="https://www.skyminds.net/comments/feed/"><link rel="alternate" type="application/rss+xml" title="SkyMinds.Net &raquo; MariaDB : r&eacute;soudre l&rsquo;erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es Comments Feed" href="https://www.skyminds.net/mariadb-1062-duplicate-entry-replication/feed/"><meta content="skyminds16 v.1.5-2017" name="generator"><style>.mistape-test, .mistape_mistake_inner{color:#E42029 !important;}
#mistape_dialog h2::before, #mistape_dialog .mistape_action, .mistape-letter-back{background-color:#E42029 !important;}
#mistape_reported_text:before, #mistape_reported_text:after{border-color:#E42029 !important;}
.mistape-letter-front .front-left{border-left-color:#E42029 !important;}
.mistape-letter-front .front-right{border-right-color:#E42029 !important;}
.mistape-letter-front .front-bottom, .mistape-letter-back > .mistape-letter-back-top, .mistape-letter-top{border-bottom-color:#E42029 !important;}
.mistape-logo svg{fill:#E42029 !important;}</style><style>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</style><link rel="stylesheet" id="et_monarch-css-css" href='//www.skyminds.net/wp-content/cache/wpfc-minified/ab11d09567fd310a56519d4be502c170/1499113370index.css' type="text/css" media="all"><style>code[class*="language-"],
pre[class*="language-"]{color:black;background:none;text-shadow:0 1px white;font-family:Consolas, Monaco, 'Andale Mono', 'Ubuntu Mono', monospace;text-align:left;white-space:pre;word-spacing:normal;word-break:normal;word-wrap:normal;line-height:1.5;-moz-tab-size:4;-o-tab-size:4;tab-size:4;-webkit-hyphens:none;-moz-hyphens:none;-ms-hyphens:none;hyphens:none;}
pre[class*="language-"]::-moz-selection, pre[class*="language-"] ::-moz-selection,
code[class*="language-"]::-moz-selection, code[class*="language-"] ::-moz-selection{text-shadow:none;background:#b3d4fc;}
pre[class*="language-"]::selection, pre[class*="language-"] ::selection,
code[class*="language-"]::selection, code[class*="language-"] ::selection{text-shadow:none;background:#b3d4fc;}
@media print {
code[class*="language-"],
pre[class*="language-"]{text-shadow:none;}
} pre[class*="language-"]{padding:1em;margin:.5em 0;overflow:auto;}:not(pre) > code[class*="language-"],
pre[class*="language-"]{background:#f5f2f0;}:not(pre) > code[class*="language-"]{padding:.1em;border-radius:.3em;white-space:normal;}
.token.comment,
.token.prolog,
.token.doctype,
.token.cdata{color:slategray;}
.token.punctuation{color:#999;}
.namespace{opacity:.7;}
.token.property,
.token.tag,
.token.boolean,
.token.number,
.token.constant,
.token.symbol,
.token.deleted{color:#905;}
.token.selector,
.token.attr-name,
.token.string,
.token.char,
.token.builtin,
.token.inserted{color:#690;}
.token.operator,
.token.entity,
.token.url,
.language-css .token.string,
.style .token.string{color:#a67f59;background:hsla(0, 0%, 100%, .5);}
.token.atrule,
.token.attr-value,
.token.keyword{color:#07a;}
.token.function{color:#DD4A68;}
.token.regex,
.token.important,
.token.variable{color:#e90;}
.token.important,
.token.bold{font-weight:bold;}
.token.italic{font-style:italic;}
.token.entity{cursor:help;}
pre[data-line]{position:relative;padding:1em 0 1em 3em;}
.line-highlight{position:absolute;left:0;right:0;padding:inherit 0;margin-top:1em;background:hsla(24, 20%, 50%,.08);background:linear-gradient(to right, hsla(24, 20%, 50%,.1) 70%, hsla(24, 20%, 50%,0));pointer-events:none;line-height:inherit;white-space:pre;}
.line-highlight:before,
.line-highlight[data-end]:after{content:attr(data-start);position:absolute;top:.4em;left:.6em;min-width:1em;padding:0 .5em;background-color:hsla(24, 20%, 50%,.4);color:hsl(24, 20%, 95%);font:bold 65%/1.5 sans-serif;text-align:center;vertical-align:.3em;border-radius:999px;text-shadow:none;box-shadow:0 1px white;}
.line-highlight[data-end]:after{content:attr(data-end);top:auto;bottom:.4em;}
pre.line-numbers{position:relative;padding-left:3.8em;counter-reset:linenumber;}
pre.line-numbers > code{position:relative;}
.line-numbers .line-numbers-rows{position:absolute;pointer-events:none;top:0;font-size:100%;left:-3.8em;width:3em;letter-spacing:-1px;border-right:1px solid #999;-webkit-user-select:none;-moz-user-select:none;-ms-user-select:none;user-select:none;}
.line-numbers-rows > span{pointer-events:none;display:block;counter-increment:linenumber;}
.line-numbers-rows > span:before{content:counter(linenumber);color:#999;display:block;padding-right:0.8em;text-align:right;}</style><style id="prism-css-inline-css">pre[class*="language-"]{clear:both;margin-bottom:1.5em}</style><style>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</style><style>#toc_container li,#toc_container ul{margin:0;padding:0}
#toc_container.no_bullets li,#toc_container.no_bullets ul,#toc_container.no_bullets ul li,.toc_widget_list.no_bullets,.toc_widget_list.no_bullets li{background:0 0;list-style-type:none;list-style:none}
#toc_container.have_bullets li{padding-left:12px}
#toc_container ul ul{margin-left:1.5em}
#toc_container{background:#f9f9f9;border:1px solid #aaa;padding:10px;margin-bottom:1em;width:auto;display:table;font-size:95%}
#toc_container.toc_light_blue{background:#edf6ff}
#toc_container.toc_white{background:#fff}
#toc_container.toc_black{background:#000}
#toc_container.toc_transparent{background:none transparent}
#toc_container p.toc_title{text-align:center;font-weight:700;margin:0;padding:0}
#toc_container.toc_black p.toc_title{color:#aaa}
#toc_container span.toc_toggle{font-weight:400;font-size:90%}
#toc_container p.toc_title+ul.toc_list{margin-top:1em}
.toc_wrap_left{float:left;margin-right:10px}
.toc_wrap_right{float:right;margin-left:10px}
#toc_container a{text-decoration:none;text-shadow:none}
#toc_container a:hover{text-decoration:underline}
.toc_sitemap_posts_letter{font-size:1.5em;font-style:italic}</style><link rel="stylesheet" id="woocommerce-layout-css" href='//www.skyminds.net/wp-content/cache/wpfc-minified/a4506621ed2a58823e1829191432a853/1499113370index.css' type="text/css" media="all"><link rel="stylesheet" id="woocommerce-smallscreen-css" href='//www.skyminds.net/wp-content/cache/wpfc-minified/5f60fe801e349f1e7d990320e892bc0a/1499113370index.css' type="text/css" media="only screen and (max-width: 768px)"><link rel="stylesheet" id="woocommerce-general-css" href='//www.skyminds.net/wp-content/cache/wpfc-minified/ac9627502f2e49249cae323a3f447035/1499113370index.css' type="text/css" media="all"><style>.wp-pagenavi{clear:both;}
.wp-pagenavi a, .wp-pagenavi span{text-decoration:none;border:1px solid #BFBFBF;padding:3px 5px;margin:2px;}
.wp-pagenavi a:hover, .wp-pagenavi span.current{border-color:#000;}
.wp-pagenavi span.current{font-weight:bold;}</style><link rel="stylesheet" id="mistape-front-css" href='//www.skyminds.net/wp-content/cache/wpfc-minified/ee5908575cf74c31653e9676cdc3d779/1499113370index.css' type="text/css" media="all"><style>.wcppec-checkout-buttons{text-align:center;margin:1em 0;overflow:hidden;}
.wcppec-checkout-buttons__separator{display:block;opacity:.5;margin:0 0 1em;}
.wcppec-checkout-buttons__button{display:block;text-decoration:none !important;border:0 !important;padding-top:1em;}
.wcppec-checkout-buttons__button img{margin:0 auto;}
.paypal-button-widget .paypal-button,
.paypal-button-widget .paypal-button:hover{background:transparent;box-shadow:none;border:none;}
.wcppec-cart-widget-button{display:inline-block;text-decoration:none !important;border:0 !important;}</style><link rel="stylesheet" id="parent-style-css" href='//www.skyminds.net/wp-content/cache/wpfc-minified/17c2d1a472bbd486b68ff6de2b22340a/1499113370index.css' type="text/css" media="all"><style>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</style><style>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</style><link rel="stylesheet" id="et-shortcodes-css-css" href='//www.skyminds.net/wp-content/cache/wpfc-minified/a31c510d28e5ccd3add1bbe2348eb6c4/1499113370index.css' type="text/css" media="all"><style>body.et_right_sidebar .pricing-table, body.et_left_sidebar .pricing-table{width:50%;}
@media all and ( max-width: 959px ) {
body.et_right_sidebar .one_third, body.et_right_sidebar .one_half, body.et_right_sidebar .one_third, body.et_right_sidebar .two_third, body.et_right_sidebar .one_fourth, body.et_right_sidebar .three_fourth,
body.et_left_sidebar .one_third, body.et_left_sidebar .one_half, body.et_left_sidebar .one_third, body.et_left_sidebar .two_third, body.et_left_sidebar .one_fourth, body.et_left_sidebar .three_fourth{float:none;margin-right:0;width:auto;margin-bottom:10px;}
body.et_right_sidebar .et-testimonial-box, body.et_right_sidebar .et-protected,
body.et_left_sidebar .et-testimonial-box, body.et_left_sidebar .et-protected{width:auto !important;}
body.et_right_sidebar .et-protected-form,
body.et_left_sidebar .et-protected-form{padding:15px !important;}
}
@media all and (min-width: 768px) and (max-width: 959px) {
body.et_full_width_page .pricing-table{width:50%;}
}
@media all and ( max-width: 767px ) {
.et_left_tabs_bg{width:50px;}
.tabs-left .et-tabs-control, .et-tabs-container .et-tabs-control{display:none;}
.tabs-left ul.et_shortcodes_mobile_nav{display:block;width:51px;}
.tabs-left ul.et_shortcodes_mobile_nav a{display:block;height:49px;width:100%;}
.tabs-left .et-tabs-content{margin-left:75px;}
.et-tabs-container  ul.et_shortcodes_mobile_nav{display:block;}
.et-tabs-container  ul.et_shortcodes_mobile_nav li{width:50%;}
.et-pricing{margin-top:0;}
body.et_right_sidebar .pricing-table, body.et_left_sidebar .pricing-table, body.et_full_width_page .pricing-table{width:100%;margin-bottom:35px;}
.pricing-big{top:0;}
body.et_full_width_page .one_third, body.et_full_width_page .one_half, body.et_full_width_page .one_third, body.et_full_width_page .two_third, body.et_full_width_page .one_fourth, body.et_full_width_page .three_fourth{float:none;margin-right:0;width:auto;margin-bottom:10px;}
body.et_full_width_page .et-testimonial-box, body.et_full_width_page .et-protected{width:auto !important;}
body.et_full_width_page .et-protected-form{padding:15px !important;}
body.et_right_sidebar .author-shortcodes .author-inner,
body.et_left_sidebar .author-shortcodes .author-inner{padding:27px 27px 17px;}
body.et_right_sidebar .author-shortcodes .author-image,
body.et_left_sidebar .author-shortcodes .author-image{position:relative;top:0;left:0;margin-bottom:10px;}
body.et_right_sidebar .quote-center .et_quote_additional_sign,
body.et_left_sidebar .quote-center .et_quote_additional_sign{right:-13px;}
body.et_right_sidebar .et_shortcodes_controls,
body.et_left_sidebar .et_shortcodes_controls{display:none;}
body.et_right_sidebar .et_shortcodes_controls_arrows a,
body.et_left_sidebar .et_shortcodes_controls_arrows a{text-indent:-9999px;}
}
@media all and ( max-width: 479px ) {
.et-tabs-container ul.et_shortcodes_mobile_nav a.et_sc_nav_prev{padding-left:26px;}
.et-tabs-container ul.et_shortcodes_mobile_nav .et_sc_nav_prev span{left:10px;}
.et-tabs-container ul.et_shortcodes_mobile_nav a.et_sc_nav_next{padding-right:26px;}
.et-tabs-container ul.et_shortcodes_mobile_nav .et_sc_nav_next span{right:10px;}
body.et_full_width_page .author-shortcodes .author-inner{padding:27px 27px 17px;}
body.et_full_width_page .author-shortcodes .author-image{position:relative;top:0;left:0;margin-bottom:10px;}
body.et_full_width_page .quote-center .et_quote_additional_sign{right:-13px;}
body.et_full_width_page .et_shortcodes_controls{display:none;}
body.et_full_width_page .et_shortcodes_controls_arrows a{text-indent:-9999px;}
.et-box:before, .et-testimonial:before{display:none;}
.et-box-content{padding:27px 27px 17px 27px;}
.et-testimonial{padding:25px;}
}</style><style>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</style><link rel="stylesheet" id="dashicons-css" href='//www.skyminds.net/wp-content/cache/wpfc-minified/0d6a19a745c39610c1add2fdeaadb55a/1499113377index.css' type="text/css" media="all"><link rel="stylesheet" id="jetpack_css-css" href='//www.skyminds.net/wp-content/cache/wpfc-minified/54767f3ab8b51dda0051c23fef36c2c9/1499113370index.css' type="text/css" media="all"><link rel="https://api.w.org/" href="https://www.skyminds.net/wp-json/"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.skyminds.net/xmlrpc.php?rsd"><link rel="alternate" type="application/json+oembed" href="https://www.skyminds.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F"><link rel="alternate" type="text/xml+oembed" href="https://www.skyminds.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;format=xml"><style>.ginger_container.light{}
.ginger_banner{padding:10px 10px !important}
.ginger_message{text-align:center}
a.ginger_btn,a.ginger_btn:hover{text-align:center !important;margin:10px 60px !important;width:130px !important}</style><style id="et-social-custom-css"></style><style>.empty-cart .et-cart-info{display:none !important}</style><style>div#toc_container{width:400px;}</style><style>img#wpstats{display:none}</style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0"><noscript><style>.woocommerce-product-gallery{opacity:1 !important;}</style></noscript><link rel="amphtml" href="https://www.skyminds.net/mariadb-1062-duplicate-entry-replication/amp/"><meta name="google-site-verification" content="-OCgXvO2zlzRFNI0T7oBUNUi3UN9OZqYyfI5IhPOj2s"><meta name="google-site-verification" content="-OCgXvO2zlzRFNI0T7oBUNUi3UN9OZqYyfI5IhPOj2s"><style id="et-core-unified-cached-inline-styles">@media only screen and (min-width:767px){body,.et_pb_column_1_2 .et_quote_content blockquote cite,.et_pb_column_1_2 .et_link_content a.et_link_main_url,.et_pb_column_1_3 .et_quote_content blockquote cite,.et_pb_column_3_8 .et_quote_content blockquote cite,.et_pb_column_1_4 .et_quote_content blockquote cite,.et_pb_blog_grid .et_quote_content blockquote cite,.et_pb_column_1_3 .et_link_content a.et_link_main_url,.et_pb_column_3_8 .et_link_content a.et_link_main_url,.et_pb_column_1_4 .et_link_content a.et_link_main_url,.et_pb_blog_grid .et_link_content a.et_link_main_url,body .et_pb_bg_layout_light .et_pb_post p,body .et_pb_bg_layout_dark .et_pb_post p{font-size:20px}
.et_pb_slide_content,.et_pb_best_value{font-size:22px}}body{line-height:2em}
.container,.et_pb_row,.et_pb_slider .et_pb_container,.et_pb_fullwidth_section .et_pb_title_container,.et_pb_fullwidth_section .et_pb_title_featured_container,.et_pb_fullwidth_header:not(.et_pb_fullscreen) .et_pb_fullwidth_header_container{max-width:1365px}
.et_boxed_layout #page-container,.et_fixed_nav.et_boxed_layout #page-container #top-header,.et_fixed_nav.et_boxed_layout #page-container #main-header,.et_boxed_layout #page-container .container,.et_boxed_layout #page-container .et_pb_row{max-width:1525px}
#top-header,#top-header a,#et-secondary-nav li li a,#top-header .et-social-icon a:before{font-size:13px}
#top-menu li a{font-size:16px}
body.et_vertical_nav .container.et_search_form_container .et-search-form input{font-size:16px!important}
#footer-widgets .footer-widget li:before{top:14px}
h1,h2,h3,h4,h5,h6,.et_quote_content blockquote p,.et_pb_slide_description .et_pb_slide_title{line-height:1.4em}
@media only screen and (min-width:981px){#logo{max-height:90%}
.et_pb_svg_logo #logo{height:90%}
.et_header_style_centered.et_hide_primary_logo #main-header:not(.et-fixed-header) .logo_container,.et_header_style_centered.et_hide_fixed_logo #main-header.et-fixed-header .logo_container{height:11.88px}
body.home-posts #left-area .et_pb_post h2,body.archive #left-area .et_pb_post h2,body.search #left-area .et_pb_post h2{font-size:28.6px}
body.single .et_post_meta_wrapper h1{font-size:33px}}@media only screen and (min-width:1706px){.et_pb_row{padding:34px 0}
.et_pb_section{padding:68px 0}
.single.et_pb_pagebuilder_layout.et_full_width_page .et_post_meta_wrapper{padding-top:102px}
.et_pb_section.et_pb_section_first{padding-top:inherit}
.et_pb_fullwidth_section{padding:0}}h1,h2,h3,h4,h5,h6{font-family:'Droid Sans',Helvetica,Arial,Lucida,sans-serif}
body,input,textarea,select{font-family:'Open Sans',Helvetica,Arial,Lucida,sans-serif}</style><script>var async_ginger_script=["\/\/pagead2.googlesyndication.com\/pagead\/js\/adsbygoogle.js"];</script></head><body class="post-template-default single single-post postid-28709 single-format-standard et_monarch empty-cart et_pb_button_helper_class et_fixed_nav et_show_nav et_secondary_nav_enabled et_pb_gutter et_pb_gutters3 et_primary_nav_dropdown_animation_fade et_secondary_nav_dropdown_animation_fade et_pb_footer_columns2 et_header_style_left et_right_sidebar et_divi_theme unknown">
<div id="page-container"> <div id="top-header"> <div class="container clearfix"> <div id="et-secondary-menu"> <ul class="et-social-icons"><li class="et-social-icon et-social-facebook"> <a href="https://www.facebook.com/skyminds" class="icon"> <span>Facebook</span> </a> </li> <li class="et-social-icon et-social-twitter"> <a href="https://twitter.com/skyminds" class="icon"> <span>Twitter</span> </a> </li> <li class="et-social-icon et-social-google-plus"> <a href="https://www.google.com/+SkymindsNet" class="icon"> <span>Google</span> </a> </li> <li class="et-social-icon et-social-rss"> <a href="https://www.skyminds.net/feed/" class="icon"> <span>RSS</span> </a> </li> </ul><ul id="et-secondary-nav" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8520"><a href="https://www.skyminds.net/contact/">Contact</a></li> <li id="log-in-out-link" class="menu-item menu-type-link"><a href="https://www.skyminds.net/wp-login.php" title="Login">Login</a></li></ul></div></div></div><header id="main-header" data-height-onload="66"><div class="container clearfix et_menu_container"> <div class="logo_container"> <span class="logo_helper"></span> <a href="https://www.skyminds.net/"> <img src="https://www.skyminds.net/wp-content/themes/skyminds16/logo-skyminds16.png" alt="SkyMinds.Net" id="logo" data-height-percentage="90"></a></div><div id="et-top-navigation" data-height="66" data-fixed-height="40"> <nav id="top-menu-nav"><ul id="top-menu" class="nav"><li id="menu-item-29004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29004"><a href="https://www.skyminds.net/realisation-de-votre-projet-web/">R&eacute;alisation de votre projet web</a></li> <li id="menu-item-27933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27933"><a href="https://www.skyminds.net/maintenance-de-votre-site-internet/">Infog&eacute;rance</a></li> <li id="menu-item-27939" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27939"><a href="https://www.skyminds.net/webtech/">Tutos Web/Tech</a></li> <li id="menu-item-27940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27940"><a href="https://www.skyminds.net/wordpress/">WordPress</a></li> <li id="menu-item-27935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27935"><a href="https://www.skyminds.net/music-series/">Music/S&eacute;ries</a></li> <li id="menu-item-27936" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-27936"><a href="https://www.skyminds.net/mister-b/">Mister B.</a> <ul class="sub-menu"><li id="menu-item-27938" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27938"><a href="https://www.skyminds.net/litterature/">Litt&eacute;rature</a></li> <li id="menu-item-27937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27937"><a href="https://www.skyminds.net/economie-sociologie/">Economie-Sociologie</a></li> </ul></li> </ul></nav><div id="et_top_search"> <span id="et_search_icon"></span></div><div id="et_mobile_nav_menu"> <div class="mobile_nav closed"> <span class="select_page">Select Page</span> <span class="mobile_menu_bar mobile_menu_bar_toggle"></span></div></div></div></div><div class="et_search_outer"> <div class="container et_search_form_container"> <form method="get" class="et-search-form" action="https://www.skyminds.net/"> <input type="search" class="et-search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:"><input type="submit" name="Go" value="Go" class="screenreader"></form> <span class="et_close_search_field"></span></div></div></header><div id="et-main-area"><div id="main-content"> <div class="container"> <div id="content-area" class="clearfix"> <div id="left-area"> <article id="post-28709" class="et_pb_post post-28709 post type-post status-publish format-standard has-post-thumbnail hentry category-webtech tag-base-de-donnees tag-mariadb tag-replication tag-root tag-terminal tag-tuto tag-vps"><div class="et_post_meta_wrapper"> <h1 class="entry-title">MariaDB : r&eacute;soudre l&rsquo;erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es</h1> <p class="post-meta">par <span class="vcard fn author"><a href="https://www.skyminds.net/author/matt/" title="Posts by Matt" class="author url fn" rel="author">Matt</a></span><span class="vcard"> | <span class="published updated">vendredi 7 juillet 2017</span> | <a href="https://www.skyminds.net/webtech/" rel="tag">Web/Tech</a> | <span class="comments-number"><a href="https://www.skyminds.net/mariadb-1062-duplicate-entry-replication/#respond">0 comments</a></span></span></p></div><div class="entry-content"> <div class="ttr_start"></div><ins class="adsbygoogle" data-ad-client="ca-pub-1521551724374415" data-ad-slot="1776183598" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script><p>Si vous utilisez les <a href="https://www.skyminds.net/creer-serveur-high-availability-replication-bases-donnees/">fonctions de r&eacute;plication de MySQL ou MariaDB</a>, il peut arriver que votre slave bloque sur une instruction qui devrait avoir un identifiant unique mais que le serveur tente d&rsquo;ins&eacute;rer deux fois. </p>
<p><img src="https://static.skyminds.net/mariadb-replication-and-ha.png" alt="Cr&eacute;er un serveur High Availability : la r&eacute;plication des bases de donn&eacute;es photo" width="1200" height="407" class="aligncenter size-full wp-image-28740" srcset="https://static.skyminds.net/mariadb-replication-and-ha.png 1200w, https://static.skyminds.net/mariadb-replication-and-ha-660x224.png 660w, https://static.skyminds.net/mariadb-replication-and-ha-768x260.png 768w, https://static.skyminds.net/mariadb-replication-and-ha-100x34.png 100w, https://static.skyminds.net/mariadb-replication-and-ha-150x51.png 150w, https://static.skyminds.net/mariadb-replication-and-ha-510x173.png 510w, https://static.skyminds.net/mariadb-replication-and-ha-1080x366.png 1080w" sizes="(max-width: 1200px) 100vw, 1200px"></p>
<p>Et quand c&rsquo;est le cas, la r&eacute;plication des donn&eacute;es prend fin donc c&rsquo;est un probl&egrave;me &agrave; corriger rapidement si vous voulez que votre syst&egrave;me haute disponibilit&eacute; perdure et soit vraiment efficace en cas de coup dur.</p>
<h2>Identification du probl&egrave;me</h2>
<p>Je me suis rendu compte du probl&egrave;me lorsque j&rsquo;ai ajout&eacute; de nouvelles bases &agrave; r&eacute;pliquer : j&rsquo;ai relanc&eacute; la proc&eacute;dure d&rsquo;installation, relanc&eacute; les serveurs, ajout&eacute; les nouvelles positions, d&eacute;marr&eacute; les slaves.</p>
<p>On regarde le status du slave :</p>
<pre><code class="language-bash">MariaDB [(none)]&gt; SHOW SLAVE STATUS\G</code></pre>
<p>R&eacute;sultat :</p><a target="_blank" href="https://www.skyminds.net/out/wpengine"><img src="https://static.skyminds.net/2017/07/wpengine-728x90-compressor.png" class="tuquoque"></a>
<pre><code class="language-bash">*************************** 1. row ***************************
Slave_IO_State: Waiting for master to send event
Master_Host: 10.134.23.164
Master_User: replicator
Master_Port: 3306
Connect_Retry: 60
Master_Log_File: mariadb-bin.000210
Read_Master_Log_Pos: 2753885
Relay_Log_File: mysqld-relay-bin.000002
Relay_Log_Pos: 103794
Relay_Master_Log_File: mariadb-bin.000210
Slave_IO_Running: Yes
Slave_SQL_Running: No
Replicate_Do_DB:
Replicate_Ignore_DB:
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table:
Last_Errno: 1062
Last_Error: Error 'Duplicate entry '56-724' for key 'PRIMARY'' on query. Default database: 'frenchy'. Query: 'INSERT INTO `wp_term_relationships` (`object_id`, `term_taxonomy_id`) VALUES (56, 724)'
Skip_Counter: 0
Exec_Master_Log_Pos: 1563407
Relay_Log_Space: 1296874
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: No
Master_SSL_CA_File:
Master_SSL_CA_Path:
Master_SSL_Cert:
Master_SSL_Cipher:
Master_SSL_Key:
Seconds_Behind_Master: NULL
Master_SSL_Verify_Server_Cert: No
Last_IO_Errno: 0
Last_IO_Error:
Last_SQL_Errno: 1062
Last_SQL_Error: Error 'Duplicate entry '56-724' for key 'PRIMARY'' on query. Default database: 'frenchy'. Query: 'INSERT INTO `wp_term_relationships` (`object_id`, `term_taxonomy_id`) VALUES (56, 724)'
Replicate_Ignore_Server_Ids:
Master_Server_Id: 1
Master_SSL_Crl:
Master_SSL_Crlpath:
Using_Gtid: No
Gtid_IO_Pos:
Replicate_Do_Domain_Ids:
Replicate_Ignore_Domain_Ids:
Parallel_Mode: conservative
1 row in set (0.00 sec)</code></pre>
<p>Comme on peut le constater, plusieurs choses ne tournent pas rond et emp&ecirc;chent la synchronisation des donn&eacute;es entre nos deux serveurs :</p>
<pre><code class="language-bash">Slave_SQL_Running: No
Last_SQL_Errno: 1062
Last_SQL_Error: Error 'Duplicate entry '56-724' for key 'PRIMARY'' on query. Default database: 'frenchy'. Query: 'INSERT INTO `wp_term_relationships` (`object_id`, `term_taxonomy_id`) VALUES (56, 724)'</code></pre>
<h2>Solution : un RESET sur le slave</h2>
<p>En me documentant sur le probl&egrave;me, j&rsquo;ai lu pas mal de choses sur le net. Certains pr&eacute;f&egrave;rent cacher l&rsquo;erreur, au risque de perdre des donn&eacute;es. D&rsquo;autres pr&eacute;f&egrave;rent tout effacer pour recommencer la r&eacute;plication.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://www.skyminds.net/eliminer-le-cheval-de-troie-msn-qui-touche-facebook/" target="_blank" class="ue4abf2050614574cd02507d59c45af4a"><style>.ue4abf2050614574cd02507d59c45af4a{padding:0px;margin:0;padding-top:1em!important;padding-bottom:1em!important;width:100%;display:block;font-weight:bold;background-color:#ECF0F1;border:0!important;border-left:4px solid #27AE60!important;text-decoration:none;}
.ue4abf2050614574cd02507d59c45af4a:active, .ue4abf2050614574cd02507d59c45af4a:hover{opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms;text-decoration:none;}
.ue4abf2050614574cd02507d59c45af4a{transition:background-color 250ms;webkit-transition:background-color 250ms;opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms;}
.ue4abf2050614574cd02507d59c45af4a .ctaText{font-weight:bold;color:#000000;text-decoration:none;font-size:16px;}
.ue4abf2050614574cd02507d59c45af4a .postTitle{color:#3498DB;text-decoration:underline!important;font-size:16px;}
.ue4abf2050614574cd02507d59c45af4a:hover .postTitle{text-decoration:underline!important;}</style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">A lire :</span>&nbsp; <span class="postTitle">Eliminer le cheval de troie MSN qui touche Facebook</span></div></a></div><p>Aucune de ces &ldquo;solutions&rdquo; ne me conviennent donc nous allons proc&eacute;der autrement. Comme l&rsquo;erreur n&rsquo;appara&icirc;t que sur le serveur <code>BACKUP</code> et non sur le serveur principal, c&rsquo;est sur lui que nous travaillerons.</p>
<p>Sur le serveur <code>BACKUP</code>, dans MariaDB, on arr&ecirc;te notre slave :</p>
<ins class="adsbygoogle" data-ad-client="ca-pub-1521551724374415" data-ad-slot="1776183598" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script><pre><code class="language-bash">MariaDB [(none)]&gt; STOP SLAVE;
Query OK, 0 rows affected (0.01 sec)</code></pre>
<p>On flush les privil&egrave;ges et donc les utilisateurs connect&eacute;s :</p>
<pre><code class="language-bash">MariaDB [(none)]&gt; FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.00 sec)</code></pre>
<p>On efface les fichiers logs de notre slave. C&rsquo;est comme effacer une ardoise pour repartir sur des bases saines. Cela ne supprime aucune donn&eacute;e &ndash; <a href="https://dev.mysql.com/doc/refman/5.7/en/reset-slave.html">cf le manuel sur RESET</a> :</p>
<pre><code class="language-bash">MariaDB [(none)]&gt; RESET SLAVE;
Query OK, 0 rows affected (0.00 sec)</code></pre>
<p>Et on red&eacute;marre notre slave :</p><p class="centered">
<ins class="adsbygoogle" style="width:728px;height:15px" data-ad-client="ca-pub-1521551724374415" data-ad-slot="9482702397"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></p>
<pre><code class="language-bash">MariaDB [(none)]&gt; START SLAVE;
Query OK, 0 rows affected (0.00 sec)</code></pre>
<p>On v&eacute;rifie de nouveau le status de notre slave :</p>
<pre><code class="language-bash">MariaDB [(none)]&gt; SHOW SLAVE STATUS\G</code></pre>
<p>R&eacute;sultat :</p>
<pre><code class="language-bash">*************************** 1. row ***************************
Slave_IO_State: Waiting for master to send event
Master_Host: 10.134.23.164
Master_User: replicator
Master_Port: 3306
Connect_Retry: 60
Master_Log_File: mariadb-bin.000196
Read_Master_Log_Pos: 77900062
Relay_Log_File: mysqld-relay-bin.000002
Relay_Log_Pos: 6318821
Relay_Master_Log_File: mariadb-bin.000192
Slave_IO_Running: Yes
Slave_SQL_Running: Yes
Replicate_Do_DB:
Replicate_Ignore_DB:
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table:
Last_Errno: 0
Last_Error:
Skip_Counter: 0
Exec_Master_Log_Pos: 6318531
Relay_Log_Space: 344030331
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: No
Master_SSL_CA_File:
Master_SSL_CA_Path:
Master_SSL_Cert:
Master_SSL_Cipher:
Master_SSL_Key:
Seconds_Behind_Master: 833890
Master_SSL_Verify_Server_Cert: No
Last_IO_Errno: 0
Last_IO_Error:
Last_SQL_Errno: 0
Last_SQL_Error:
Replicate_Ignore_Server_Ids:
Master_Server_Id: 1
Master_SSL_Crl:
Master_SSL_Crlpath:
Using_Gtid: No
Gtid_IO_Pos:
Replicate_Do_Domain_Ids:
Replicate_Ignore_Domain_Ids:
Parallel_Mode: conservative
1 row in set (0.00 sec)</code></pre>
<p>Nous avons bien : </p><p class="centered">
<ins class="adsbygoogle" style="width:728px;height:15px" data-ad-client="ca-pub-1521551724374415" data-ad-slot="9482702397"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></p>
<pre><code class="language-bash">Slave_IO_Running: Yes
Slave_SQL_Running: Yes</code></pre>
<p>Et voil&agrave;, plus d&rsquo;erreur et une r&eacute;plication active dans les deux sens.</p>
<div class="ttr_end"></div><div class="leadbox">Vous avez besoin d'un d&eacute;veloppeur expert WordPress et WooCoommerce ou de l'expertise d'un sysadmin ?<br><a class="et_pb_promo_button et_pb_button et_pb_custom_button_icon" href="https://www.skyminds.net/realisation-de-votre-projet-web/" data-icon="&#57606;">Contactez Matt! </a></div><div class="mistape_caption"><span class="mistape-link-wrap"><span class="mistape-link mistape-logo"><svg version="1.1" id="Capa_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="95.864px" height="95.864px" viewbox="0 0 95.864 95.864" style="enable-background:new 0 0 95.864 95.864;" xml:space="preserve"><g><g><path d="M26.847,43.907c0.279,0.805,1.037,1.345,1.889,1.345h5.59c0.656,0,1.271-0.322,1.645-0.862s0.459-1.229,0.227-1.843 L23.632,9.19c-0.293-0.779-1.039-1.295-1.871-1.295h-6.869c-0.826,0-1.568,0.509-1.865,1.28L0.134,42.582 c-0.236,0.615-0.156,1.308,0.217,1.852c0.373,0.543,0.99,0.868,1.65,0.868h5.07c0.836,0,1.584-0.52,1.875-1.303l2.695-7.247 h12.723L26.847,43.907z M14.027,29.873l4.154-12.524l3.9,12.524H14.027z"></path><path d="M39.711,45.25h10.01c3.274,0,9.371,0,13.272-4.488c2.14-2.482,2.39-7.353,1.609-9.807 c-0.836-2.395-2.43-4.028-5.103-5.193c2.015-1.046,3.437-2.515,4.234-4.382c1.207-2.857,0.596-6.954-1.434-9.55 c-2.781-3.471-7.6-3.939-11.949-3.939L39.709,7.896c-1.104,0-1.998,0.896-1.998,2V43.25C37.711,44.355,38.606,45.25,39.711,45.25z M55.375,35.911c-0.586,1.227-1.813,2.361-6.811,2.361H47.28V29.56l1.813-0.001c2.971,0,4.705,0.295,5.93,1.894 C55.877,32.587,55.92,34.806,55.375,35.911z M54.625,20.298c-0.854,1.514-2.039,2.333-5.712,2.333H47.28v-7.808l1.847-0.001 c2.609,0.064,4.123,0.343,5.115,1.658C55.05,17.592,55.007,19.458,54.625,20.298z"></path><path d="M95.677,38.77c-0.031-0.632-0.359-1.212-0.886-1.563c-0.524-0.353-1.188-0.436-1.782-0.224 c-4.802,1.706-8.121,1.787-11.17,0.258c-3.761-1.946-5.666-5.227-5.824-9.99c-0.062-4.17,0.528-8.79,5.358-11.445 c1.416-0.775,3.07-1.168,4.92-1.168c2.461,0,4.9,0.723,6.515,1.328c0.598,0.227,1.266,0.149,1.799-0.199 c0.535-0.351,0.869-0.935,0.9-1.572l0.18-3.542c0.047-0.94-0.568-1.787-1.478-2.031c-2.006-0.541-5.149-1.185-8.745-1.185 c-3.873,0-7.265,0.733-10.085,2.183c-7.836,4.055-9.102,11.791-9.278,14.92c-0.181,2.901-0.123,12.788,8.117,18.195 c3.883,2.5,8.541,3.024,11.764,3.024c2.816,0,5.812-0.417,8.438-1.175c0.892-0.258,1.488-1.094,1.443-2.02L95.677,38.77z"></path><path d="M88.453,49.394c-0.067-0.531-0.346-1.016-0.772-1.34c-0.429-0.325-0.968-0.463-1.498-0.388 c-20.898,3.031-38.422,16.966-47.236,25.268l-16.85-19.696c-0.717-0.841-1.98-0.938-2.818-0.222l-6.471,5.533 c-0.404,0.346-0.654,0.836-0.695,1.364s0.131,1.054,0.475,1.455l21.268,24.861c1.061,1.238,2.525,2.003,4.041,2.146 c0.17,0.022,0.393,0.052,0.738,0.052c1.039,0,3.023-0.272,4.646-2.104c0.203-0.226,20.568-22.684,44.559-26.252 c1.075-0.16,1.825-1.152,1.688-2.23L88.453,49.394z"></path></g></g></svg></span></span><p>Si vous avez trouv&eacute; une faute d&rsquo;orthographe, informez-nous en s&eacute;lectionnant le texte en question et en appuyant sur Ctrl + Entr&eacute;e s&rsquo;il vous pla&icirc;t.</p></div><p class="post-tags">Tags : <a href="https://www.skyminds.net/tag/base-de-donnees/" rel="tag">base de donn&eacute;es</a>, <a href="https://www.skyminds.net/tag/mariadb/" rel="tag">MariaDB</a>, <a href="https://www.skyminds.net/tag/replication/" rel="tag">r&eacute;plication</a>, <a href="https://www.skyminds.net/tag/root/" rel="tag">root</a>, <a href="https://www.skyminds.net/tag/terminal/" rel="tag">terminal</a>, <a href="https://www.skyminds.net/tag/tuto/" rel="tag">tuto</a>, <a href="https://www.skyminds.net/tag/vps/" rel="tag">VPS</a></p></div><ins class="adsbygoogle" data-ad-client="ca-pub-1521551724374415" data-ad-slot="7873957199" data-ad-format="autorelaxed"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script><div id="prev-next"> <div class="prev-link">&larr; Article pr&eacute;c&eacute;dent <a href="https://www.skyminds.net/serveur-dedie-upgrade-debian-9-stretch/" rel="prev">Serveur d&eacute;di&eacute; : mise &agrave; jour vers Debian 9 Stretch</a></div></div><div class="author-bio" itemprop="author" itemscope itemtype="https://schema.org/Person"><p><span class="author-photo" itemprop="image"><img alt="gravatar" src="https://static.skyminds.net/Matt_avatar_1412176075-96x96.jpg" class="avatar avatar-96 photo" height="96" width="96"></span><span itemprop="name">Matt</span> a d&eacute;j&agrave; &eacute;crit <a rel="author" href="https://www.skyminds.net/author/matt/" itemprop="url">2738 articles</a> sur <a href="https://www.skyminds.net">SkyMinds.Net</a>.</p><p itemprop="description">Fan de webdesign, de programmation, d'automatisation, et d'administration r&eacute;seau, Matt est formateur, sysadmin et responsable &eacute;ditorial du site. Il s'occupe &eacute;galement de <a href="https://www.skyminds.net/maintenance-de-votre-site-internet/">maintenance de sites internet</a> et est d&eacute;veloppeur expert WordPress et WooCommerce.</p><p class="center"> <a title="Mon site" rel="me nofollow" href="https://www.skyminds.net/" target="_blank">Site web</a>&nbsp;&bull;&nbsp;<a title="My Google+" rel="me nofollow" href="https://plus.google.com/114535411372700844744?rel=author" target="_blank">Google+</a>&nbsp;&bull;&nbsp;<a title="My facebook" rel="me nofollow" href="https://www.facebook.com/skyminds" target="_blank">Facebook </a>&nbsp;&bull;&nbsp;<a title="My Twitter" rel="me nofollow" href="https://twitter.com/skyminds" target="_blank">Twitter</a></p></div><h3 class="related_post_title">Articles en rapport:</h3><ul class="related_post"><li><a href="https://www.skyminds.net/creer-serveur-high-availability-replication-bases-donnees/" title="Cr&eacute;er un serveur High Availability : la r&eacute;plication des bases de donn&eacute;es">Cr&eacute;er un serveur High Availability : la r&eacute;plication des bases de donn&eacute;es</a></li><li><a href="https://www.skyminds.net/creer-serveur-high-availability-replication-fichiers/" title="Cr&eacute;er un serveur High Availability : la r&eacute;plication des fichiers">Cr&eacute;er un serveur High Availability : la r&eacute;plication des fichiers</a></li><li><a href="https://www.skyminds.net/serveur-dedie-a-la-recherche-de-linode-perdue-ou-comment-resoudre-le-probleme-no-space-left-on-device/" title="Serveur d&eacute;di&eacute; : &agrave; la recherche de l&rsquo;inode perdue ou comment r&eacute;soudre le probl&egrave;me &ldquo;no space left on device&rdquo;">Serveur d&eacute;di&eacute; : &agrave; la recherche de l&rsquo;inode perdue ou comment r&eacute;soudre le probl&egrave;me &ldquo;no space left on device&rdquo;</a></li><li><a href="https://www.skyminds.net/linux-cannot-set-default-locale/" title="Linux : r&eacute;soudre l&rsquo;erreur &ldquo;Cannot set LC_ALL to default locale&rdquo;">Linux : r&eacute;soudre l&rsquo;erreur &ldquo;Cannot set LC_ALL to default locale&rdquo;</a></li><li><a href="https://www.skyminds.net/linux-creer-fichier-echange-swap-optimiser-vps/" title="Linux : cr&eacute;er un fichier d&rsquo;&eacute;change (swap) pour optimiser un VPS">Linux : cr&eacute;er un fichier d&rsquo;&eacute;change (swap) pour optimiser un VPS</a></li></ul><div class="et_post_meta_wrapper">  <section id="comment-wrap"><div id="comment-section" class="nocomments"></div><div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Laisser un commentaire</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/mariadb-1062-duplicate-entry-replication/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.skyminds.net/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
<p class="must-log-in"><a href="https://www.skyminds.net/wp-login.php">Identifez-vous</a> si vous poss&eacute;dez un compte.</p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" required></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" placeholder="Name*" value="" size="30" required><label for="author">Name</label> <span class="required">*</span></p>
<p class="comment-form-email"><input id="email" name="email" type="email" placeholder="Email*" value="" size="30" required><label for="email">Email</label> <span class="required">*</span></p>
<p class="comment-form-url"><input id="url" name="url" type="url" placeholder="URL" value="" size="30"><label for="url">Website</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit et_pb_button" value="Commenter"><input type="hidden" name="comment_post_ID" value="28709" id="comment_post_ID"><input type="hidden" name="comment_parent" id="comment_parent" value="0"></p><noscript><input type="hidden" name="JS04X7" value="NS1"></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external">Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
</form></div></section></div></article></div><div id="sidebar">
<ins class="adsbygoogle" style="width:336px;height:280px" data-ad-client="ca-pub-1521551724374415" data-ad-slot="9624274794"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script><div id="bwp_recent_comments-2" class="et_pb_widget bwp-rc-widget"><h4 class="widgettitle">Commentaires</h4>
<ul class="bwp-rc-ulist"><li class="recent-comment"><a href="https://www.skyminds.net/serveur-dedie-creation-dune-seedbox-avec-transmission/#comment-78085">Matt</a> dans <a href="https://www.skyminds.net/serveur-dedie-creation-dune-seedbox-avec-transmission/" title="Comment on Serveur d&eacute;di&eacute; : cr&eacute;ation d'une seedbox avec Transmission">Serveur d&eacute;di&eacute; : cr&eacute;ation d'une seedbox avec Transmission</a> : <span class="recent-comment-text"> Bonjour Phil, Voil&agrave; comment faire avec transmission-create : 1. Cr&eacute;e un dossier dans ton dossier transmission/completed : test-torrent 2. Cr&eacute;e un fichier de test :...</span></li>
<li class="recent-comment"><a href="https://www.skyminds.net/nas-synology-sous-titres-dlna-freebox/#comment-78084">Lordshaker</a> dans <a href="https://www.skyminds.net/nas-synology-sous-titres-dlna-freebox/" title="Comment on NAS Synology : lire des vid&eacute;os avec des fichiers de sous-titres en DLNA sur la Freebox">NAS Synology : lire des vid&eacute;os avec des fichiers de sous-titres en DLNA sur la Freebox</a> : <span class="recent-comment-text"> Bonjour, Merci pour ce tuto, j'ai adopt&eacute; la m&ecirc;me configuration, malheureusement cela ne fonctionne pas. Y a t il un raison particuli&egrave;re de choisir LG...</span></li>
<li class="recent-comment"><a href="https://www.skyminds.net/serveur-dedie-creation-dune-seedbox-avec-transmission/#comment-78083">Phil</a> dans <a href="https://www.skyminds.net/serveur-dedie-creation-dune-seedbox-avec-transmission/" title="Comment on Serveur d&eacute;di&eacute; : cr&eacute;ation d'une seedbox avec Transmission">Serveur d&eacute;di&eacute; : cr&eacute;ation d'une seedbox avec Transmission</a> : <span class="recent-comment-text"> Bonjour, aurais-tu un exemple pour ensuite cr&eacute;er un torrent priv&eacute; ? Parce que je ne sais pas quoi mettre dans la commande transmission-create ...</span></li>
<li class="recent-comment"><a href="https://www.skyminds.net/nas-synology-telecharger-automatiquement-sous-titres-subliminal/#comment-78082">Matt</a> dans <a href="https://www.skyminds.net/nas-synology-telecharger-automatiquement-sous-titres-subliminal/" title="Comment on NAS Synology : t&eacute;l&eacute;charger automatiquement les sous-titres avec Subliminal">NAS Synology : t&eacute;l&eacute;charger automatiquement les sous-titres avec Subliminal</a> : <span class="recent-comment-text"> Mise &agrave; jour de l'article: - ajout du script bash qui installe pip et subliminal s'ils ne sont pas pr&eacute;sents sur le NAS (MAJ de...</span></li>
<li class="recent-comment"><a href="https://www.skyminds.net/nas-synology-installer-entware-ipkg-applications/#comment-78081">Sandra</a> dans <a href="https://www.skyminds.net/nas-synology-installer-entware-ipkg-applications/" title="Comment on NAS Synology : installer Entware en remplacement d'IPKG pour des applications &agrave; jour">NAS Synology : installer Entware en remplacement d'IPKG pour des applications &agrave; jour</a> : <span class="recent-comment-text"> Je viens de suivre la nouvelle proc&eacute;dure pour le DSM 6.1. Quand je fais l'&eacute;tape 5 je suis toujours en Root en SSH , il...</span></li>
<li class="recent-comment"><a href="https://www.skyminds.net/nas-synology-installer-entware-ipkg-applications/#comment-78080">Sandra</a> dans <a href="https://www.skyminds.net/nas-synology-installer-entware-ipkg-applications/" title="Comment on NAS Synology : installer Entware en remplacement d'IPKG pour des applications &agrave; jour">NAS Synology : installer Entware en remplacement d'IPKG pour des applications &agrave; jour</a> : <span class="recent-comment-text"> Version DSM 6.1.2</span></li>
</ul></div><div id="text-13" class="et_pb_widget widget_text"><h4 class="widgettitle">Bon plan</h4> <div class="textwidget"><div style="background:#FAFAFA;text-align:center;padding:5px"><img src="https://static.skyminds.net/bforbank-logo-min.png" width="130" height="50" class="aligncenter" alt="130 euros offerts chez BforBank!"><p class="small">Carte Visa Premier gratuite &agrave; vie, pas de frais de tenue de compte et <strong>130 euros</strong> offerts &agrave; l'ouverture.</p> <p class="small">Code promo: <span class="bforb">QJ8E</span></p> <p><a href="https://www.bforbank.com/compte-bancaire.html" target="_blank" class="submit et_pb_button">Voir l'offre</a></p></div></div></div><div id="text-11" class="et_pb_widget widget_text"><h4 class="widgettitle">Recherche Amazon</h4> <div class="textwidget"><form method="get" action="https://www.amazon.fr/s/" target="_blank" id="amazon-search"><input type="hidden" name="url" value="search-alias=aps"><input type="hidden" name="tag" value="skymindsnet-21"><div class="amazon-input"><label for="field-keywords">Recherche:</label><input type="text" id="field-keywords" name="field-keywords" class="search-input" required placeholder="rechercher un produit"><input type="submit" name="Go" value="Go" class="amazon-button"></div></form></div></div></div></div></div></div><span class="et_pb_scroll_top et-pb-icon"></span>
<footer id="main-footer"><div class="container"> <div id="footer-widgets" class="clearfix"> <div class="footer-widget"><div id="recently_updated_posts-2" class="fwidget et_pb_widget recently_updated_posts"><h4 class="title">Derniers articles mis &agrave; jour</h4><ul id="articles-updated"><li><a href="https://www.skyminds.net/serveur-dedie-nginx-http2-ssl-php-mariadb-debian/" title="">Serveur d&eacute;di&eacute; : installer NginX avec support HTTP2 et certificat SSL, PHP, MariaDB sous Debian</a></li><li><a href="https://www.skyminds.net/nas-synology-telecharger-automatiquement-sous-titres-subliminal/" title="">NAS Synology : t&eacute;l&eacute;charger automatiquement les sous-titres avec Subliminal</a></li><li><a href="https://www.skyminds.net/nas-synology-installer-entware-ipkg-applications/" title="">NAS Synology : installer Entware en remplacement d'IPKG pour des applications &agrave; jour</a></li><li><a href="https://www.skyminds.net/realisation-de-votre-projet-web/" title="">R&eacute;alisation de votre projet web</a></li><li><a href="https://www.skyminds.net/better-call-saul-saison-3/" title="">Better Call Saul saison 3</a></li></ul><div class="clear"></div></div></div><div class="footer-widget"><div id="text-12" class="fwidget et_pb_widget widget_text"><h4 class="title">Bons plans</h4> <div class="textwidget"><ul><li><a href="http://www.priceminister.com/p/skyminds">Gagnez 7&euro; sur PriceMinister</a></li> <li><a href="https://hubic.com/home/new/?referral=RDCBRK">Gagnez 30 Go chez Hubic</a></li> <li><a href="http://www.amazon.fr/registry/wishlist/1G41TTHE51MYL?&amp;tag=skymindsnet-21">D&eacute;couvrez ma liste d'envies Amazon</a></li> <li><a href="https://www.skyminds.net/out/igraal">Recevez jusqu'&agrave; 40% de cashback chez iGraal</a></li> <li><a href="https://www.skyminds.net/out/tla">Mon&eacute;tisez votre site</a></li></ul></div></div></div></div></div><div id="footer-bottom"> <div class="container clearfix"> <ul class="et-social-icons"><li class="et-social-icon et-social-facebook"> <a href="https://www.facebook.com/skyminds" class="icon"> <span>Facebook</span> </a> </li> <li class="et-social-icon et-social-twitter"> <a href="https://twitter.com/skyminds" class="icon"> <span>Twitter</span> </a> </li> <li class="et-social-icon et-social-google-plus"> <a href="https://www.google.com/+SkymindsNet" class="icon"> <span>Google</span> </a> </li> <li class="et-social-icon et-social-rss"> <a href="https://www.skyminds.net/feed/" class="icon"> <span>RSS</span> </a> </li> </ul><p id="footer-info">&copy; 1999-2017 Matt - SkyMinds.Net. <a href="https://www.skyminds.net/vie-privee-et-informations-legales/">Mentions l&eacute;gales</a>.</p></div></div></footer></div></div><div class="et_social_pin_images_outer"> <div class="et_social_pinterest_window"> <div class="et_social_modal_header"><h3>Pin It on Pinterest</h3><span class="et_social_close"></span></div><div class="et_social_pin_images" data-permalink="https://www.skyminds.net/mariadb-1062-duplicate-entry-replication/" data-title="MariaDB : r&eacute;soudre l&rsquo;erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es" data-post_id="28709"></div></div></div><div class="et_social_sidebar_networks et_social_visible_sidebar et_social_no_animation et_social_animated et_social_rectangle et_social_sidebar_flip et_social_mobile_on"> <ul class="et_social_icons_container"><li class="et_social_facebook"> <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;t=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="facebook" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_facebook"></i> <span class="et_social_overlay"></span> </a> </li><li class="et_social_googleplus"> <a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;t=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="googleplus" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_googleplus"></i> <span class="et_social_overlay"></span> </a> </li><li class="et_social_twitter"> <a href="http://twitter.com/share?text=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es&amp;url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;via=skyminds" class="et_social_share" rel="nofollow" data-social_name="twitter" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_twitter"></i> <span class="et_social_overlay"></span> </a> </li><li class="et_social_linkedin"> <a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;title=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="linkedin" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_linkedin"></i> <span class="et_social_overlay"></span> </a> </li><li class="et_social_pinterest"> <a href="#" class="et_social_share_pinterest" rel="nofollow" data-social_name="pinterest" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_pinterest"></i> <span class="et_social_overlay"></span> </a> </li><li class="et_social_tumblr"> <a href="https://www.tumblr.com/share?v=3&amp;u=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;t=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="tumblr" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_tumblr"></i> <span class="et_social_overlay"></span> </a> </li><li class="et_social_buffer"> <a href="https://bufferapp.com/add?url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;title=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="buffer" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_buffer"></i> <span class="et_social_overlay"></span> </a> </li><li class="et_social_all_button"> <a href="#" rel="nofollow" data-location="sidebar" data-page_id="28709" data-permalink="https://www.skyminds.net/mariadb-1062-duplicate-entry-replication/" data-title="MariaDB : r&eacute;soudre l&rsquo;erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es" class="et_social_open_all"> <i class="et_social_icon et_social_icon_all_button"></i> <span class="et_social_overlay"></span> </a> </li></ul><span class="et_social_hide_sidebar et_social_icon"></span></div><div class="et_social_mobile_button"></div><div class="et_social_mobile et_social_fadein"> <div class="et_social_heading">Share This</div><span class="et_social_close"></span>
<div class="et_social_networks et_social_simple et_social_rounded et_social_left"> <ul class="et_social_icons_container"><li class="et_social_facebook"> <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;t=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="facebook" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_facebook"></i> <div class="et_social_network_label"><div class="et_social_networkname">Facebook</div></div><span class="et_social_overlay"></span> </a> </li><li class="et_social_googleplus"> <a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;t=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="googleplus" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_googleplus"></i> <div class="et_social_network_label"><div class="et_social_networkname">Google+</div></div><span class="et_social_overlay"></span> </a> </li><li class="et_social_twitter"> <a href="http://twitter.com/share?text=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es&amp;url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;via=skyminds" class="et_social_share" rel="nofollow" data-social_name="twitter" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_twitter"></i> <div class="et_social_network_label"><div class="et_social_networkname">Twitter</div></div><span class="et_social_overlay"></span> </a> </li><li class="et_social_linkedin"> <a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;title=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="linkedin" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_linkedin"></i> <div class="et_social_network_label"><div class="et_social_networkname">LinkedIn</div></div><span class="et_social_overlay"></span> </a> </li><li class="et_social_pinterest"> <a href="#" class="et_social_share_pinterest" rel="nofollow" data-social_name="pinterest" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_pinterest"></i> <div class="et_social_network_label"><div class="et_social_networkname">Pinterest</div></div><span class="et_social_overlay"></span> </a> </li><li class="et_social_tumblr"> <a href="https://www.tumblr.com/share?v=3&amp;u=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;t=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="tumblr" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_tumblr"></i> <div class="et_social_network_label"><div class="et_social_networkname">Tumblr</div></div><span class="et_social_overlay"></span> </a> </li><li class="et_social_buffer"> <a href="https://bufferapp.com/add?url=https%3A%2F%2Fwww.skyminds.net%2Fmariadb-1062-duplicate-entry-replication%2F&amp;title=MariaDB%20%3A%20r%C3%A9soudre%20l%E2%80%99erreur%201062%20%28duplicate%20entry%20for%20key%20PRIMARY%29%20lors%20de%20la%20r%C3%A9plication%20des%20bases%20de%20donn%C3%A9es" class="et_social_share" rel="nofollow" data-social_name="buffer" data-post_id="28709" data-social_type="share" data-location="sidebar"> <i class="et_social_icon et_social_icon_buffer"></i> <div class="et_social_network_label"><div class="et_social_networkname">Buffer</div></div><span class="et_social_overlay"></span> </a> </li><li class="et_social_all_button"> <a href="#" rel="nofollow" data-location="sidebar" data-page_id="28709" data-permalink="https://www.skyminds.net/mariadb-1062-duplicate-entry-replication/" data-title="MariaDB : r&eacute;soudre l&rsquo;erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es" class="et_social_open_all"> <i class="et_social_icon et_social_icon_all_button"></i> <span class="et_social_overlay"></span> </a> </li></ul></div></div><div class="et_social_mobile_overlay"></div><div id="sb_super_bar" class="default"> <div class="sbprogress-container"><span class="sbprogress-bar"></span></div><div id="sb_main_bar"> <div class="sb_text-size"> <a href="https://www.skyminds.net/webtech/">Web/Tech</a></div><div class="sb_post-data"> <h2> MariaDB : r&eacute;soudre l&rsquo;erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es&hellip; </h2> <span class="sb_author">par Matt</span> <span class="sb_ttr">Lecture: 4 min</span></div><div class="sb_prev-next-posts"> <a href="https://www.skyminds.net/serveur-dedie-upgrade-debian-9-stretch/"><i class="sbicn-left-open-1"></i></a> <div class="sb_next_post"> <div class="sb_next_post_image"> <img src="https://static.skyminds.net/2017/06/debian9-compressor-205x155.png" alt=""></div><div class="sb_next_post_info"> <span class="sb_title"> <span class="sb_category"> Web/Tech </span> <span class="sb_tcategory"> Serveur d&eacute;di&eacute; : mise &agrave; jour vers Debian 9 Stret&hellip; </span> </span></div></div></div><ul class="sb_share"><li class="sbfacebook"> <a href="#" title="Share on Facebook" class="sbsoc-fb" target="_blank"><i class="sbicn-facebook"></i> </a> </li>
<li class="sbtwitter"> <a href="#" data-via="skyminds" data-title="MariaDB : r&eacute;soudre l&rsquo;erreur 1062 (duplicate entry for key PRIMARY) lors de la r&eacute;plication des bases de donn&eacute;es" title="Share on Twitter" class="sbsoc-tw" target="_blank"><i class="sbicn-twitter"></i> </a> </li>
<li class="sbgoogle-plus"> <a href="#" title="Share on Google Plus" class="sbsoc-gplus" target="_blank"><i class="sbicn-gplus"></i> </a> </li>
<li class="sblinkedin"> <a href="#" title="Share on Linkedin" class="sbsoc-linked" target="_blank"><i class="sbicn-linkedin"></i> </a> </li>
<li class="sbpinterest"> <a href="#" title="Share on Pinterest" class="sbsoc-pint" target="_blank"><i class="sbicn-pinterest"></i> </a> </li>
</ul><div class="sb_actions"> <a class="sb_comment" href="#comments">0<i class="sbicn-comment"></i></a></div></div></div><script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client: "ca-pub-1521551724374415",    enable_page_level_ads: true});</script><div id="mistape_dialog" data-mode="comment" data-dry-run="0"> <div class="dialog__overlay"></div><div class="dialog__content"><div id="mistape_confirm_dialog" class="mistape_dialog_screen"> <div class="dialog-wrap"> <div class="dialog-wrap-top"> <h2>Spelling error report</h2> <div class="mistape_dialog_block"> <h3>The following text will be sent to our editors:</h3> <div id="mistape_reported_text"></div></div></div><div class="dialog-wrap-bottom"><div class="mistape_dialog_block comment">
<h3><label for="mistape_comment">Your comment (optional):</label></h3>
<textarea id="mistape_comment" cols="60" rows="3" maxlength="1000"></textarea></div><div class="pos-relative"></div></div></div><div class="mistape_dialog_block"> <a class="mistape_action" data-action="send" data-id="28709" role="button">Send</a> <a class="mistape_action" data-dialog-close role="button" style="display:none">Cancel</a></div><div class="mistape-letter-front letter-part"> <div class="front-left"></div><div class="front-right"></div><div class="front-bottom"></div></div><div class="mistape-letter-back letter-part"> <div class="mistape-letter-back-top"></div></div><div class="mistape-letter-top letter-part"></div></div></div></div><script>var et_site_url='https://www.skyminds.net';var et_post_id=28709;function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script>
<script>var admin_urls={"admin_ajax":"https:\/\/www.skyminds.net\/wp-admin\/admin-ajax.php","post_id":"28709","postNonce":"c7bc65ae9d"};</script>
<script>var monarchSettings={"ajaxurl":"https:\/\/www.skyminds.net\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/www.skyminds.net\/mariadb-1062-duplicate-entry-replication\/","stats_nonce":"275c817476","share_counts":"5946427ec5","follow_counts":"f88abe943f","total_counts":"161aeaacaa","media_single":"da908fe2be","media_total":"2d766bdab3","generate_all_window_nonce":"27c50e22cf","no_img_message":"No images available for sharing on this page"};</script>
<script>var tocplus={"smooth_scroll":"1","visibility_show":"montrer","visibility_hide":"cacher","width":"400px"};</script>
<script>var wc_add_to_cart_params={"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/mariadb-1062-duplicate-entry-replication\/?wc-ajax=%%endpoint%%","i18n_view_cart":"Voir le panier","cart_url":"https:\/\/www.skyminds.net\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};</script>
<script>var woocommerce_params={"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/mariadb-1062-duplicate-entry-replication\/?wc-ajax=%%endpoint%%"};</script>
<script>var wc_cart_fragments_params={"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/mariadb-1062-duplicate-entry-replication\/?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments_8fdc011913618b4fae0fa3675e06dc64"};</script>
<script>var decoMistape={"ajaxurl":"https:\/\/www.skyminds.net\/wp-admin\/admin-ajax.php"};</script>
<script>var et_pb_custom={"ajaxurl":"https:\/\/www.skyminds.net\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.skyminds.net\/wp-content\/themes\/Divi\/images","builder_images_uri":"https:\/\/www.skyminds.net\/wp-content\/themes\/Divi\/includes\/builder\/images","et_frontend_nonce":"9909fbce5d","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"104928ed30","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","ignore_waypoints":"no","is_divi_theme_used":"1","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"28709","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":""};</script>
<script>var quicktagsL10n={"closeAllOpenTags":"Close all open tags","closeTags":"close tags","enterURL":"Enter the URL","enterImageURL":"Enter the URL of the image","enterImageDescription":"Enter a description of the image","textdirection":"text direction","toggleTextdirection":"Toggle Editor Text Direction","dfw":"Distraction-free writing mode","strong":"Bold","strongClose":"Close bold tag","em":"Italic","emClose":"Close italic tag","link":"Insert link","blockquote":"Blockquote","blockquoteClose":"Close blockquote tag","del":"Deleted text (strikethrough)","delClose":"Close deleted text tag","ins":"Inserted text","insClose":"Close inserted text tag","image":"Insert image","ul":"Bulleted list","ulClose":"Close bulleted list tag","ol":"Numbered list","olClose":"Close numbered list tag","li":"List item","liClose":"Close list item tag","code":"Code","codeClose":"Close code tag","more":"Insert Read More tag"};</script>
<script async defer type="text/javascript" src="https://s0.wp.com/wp-content/js/devicepx-jetpack.js" defer></script>
<script rel="abtf">window.Abtf=function(window){var Abtf={cnf:{},h:function(cnf,css){this.cnf=cnf,cnf.proxy&&window.Abtf.proxy_setup(cnf.proxy),this.cnf.js&&!this.cnf.js[1]&&this.js(this.cnf.js[0]);var noref=!("undefined"==typeof this.cnf.noref||!this.cnf.noref);noref||this.ref(),"undefined"!=typeof cnf.gwf&&cnf.gwf[0]&&!cnf.gwf[1]&&("a"===cnf.gwf[0]?this.async(cnf.gwf[2],"webfont"):"undefined"!=typeof WebFont&&("string"==typeof cnf.gwf[0]&&(cnf.gwf[0]=eval("("+cnf.gwf[0]+")")),WebFont.load(cnf.gwf[0])))},f:function(a){a&&this.css&&this.css(),this.cnf.js&&this.cnf.js[1]&&this.js(this.cnf.js[0]),"undefined"!=typeof this.cnf.gwf&&this.cnf.gwf[0]&&this.cnf.gwf[1]&&("a"===this.cnf.gwf[0]?this.async(this.cnf.gwf[2],"webfont"):"undefined"!=typeof WebFont&&WebFont.load(this.cnf.gwf[0]))},ready:function(a,b,c){b=document,c="addEventListener",b[c]?b[c]("DocumentContentLoaded",a):window.attachEvent("onload",a)},ref:function(){"undefined"!=typeof window.console&&console.log("\n%c100","font: 1em sans-serif; color: white; background-color: #079c2d;padding:2px;","Google PageSpeed Score optimized using https://goo.gl/C1gw96\n\nTest your website: https://pagespeed.pro/tests\n\n")},async:function(a,b){!function(c){var d=c.createElement("script");d.src=a,b&&(d.id=b),d.async=!0;var e=c.getElementsByTagName("script")[0];if(e)e.parentNode.insertBefore(d,e);else{var f=document.head||document.getElementsByTagName("head")[0];f.appendChild(d)}}(document)}},SITE_URL,BASE_URL_REGEX;return Abtf}(window);Abtf.h([]);</script>
<script src='//www.skyminds.net/wp-content/cache/wpfc-minified/d5cea923d15d8989c327450f96ffd317/1499113422index.js' type="text/javascript"></script>
<script>gingeranalytics('')</script>
<script>var ginger_logger="Y";
var ginger_logger_url="https://www.skyminds.net";
var current_url="https://www.skyminds.net/mariadb-1062-duplicate-entry-replication/";
function gingerAjaxLogTime(status){
var xmlHttp=new XMLHttpRequest();
var parameters="ginger_action=time";
var url=ginger_logger_url + "?" + parameters;
xmlHttp.open("GET", url, true);
xmlHttp.setRequestHeader("Content-type", "application/x-www-form-urlencoded");
xmlHttp.onreadystatechange=function(){
if(xmlHttp.readyState==4&&xmlHttp.status==200){
var time=xmlHttp.responseText;
gingerAjaxLogger(time, status);
}}
xmlHttp.send(parameters);
}
function gingerAjaxLogger(ginger_logtime, status){
console.log(ginger_logtime);
var xmlHttp=new XMLHttpRequest();
var parameters="ginger_action=log&time=" + ginger_logtime + "&url=" + current_url + "&status=" + status;
var url=ginger_logger_url + "?" + parameters;
console.log(url);
xmlHttp.open("GET", url, true);
xmlHttp.setRequestHeader("Content-type", "application/x-www-form-urlencoded");
xmlHttp.send(parameters);
}</script>
<script type="application/ld+json">{ "@context":"http:\/\/schema.org\/", "name":"SkyMinds", "@type":"Organization", "logo":"https:\/\/www.skyminds.net\/wp-content\/themes\/skyminds16\/logo.png", "url":"https:\/\/www.skyminds.net\/", "sameAs":[ "https:\/\/twitter.com\/skyminds", "https:\/\/www.facebook.com\/skyminds", "https:\/\/plus.google.com\/+SkymindsNet" ], "contactPoint":[ { "@type":"ContactPoint", "telephone":"+33 649 685 665", "email":"hello@skyminds.net", "contactType":"sales" } ] }</script>
<script type="application/ld+json">{ "@context":"http:\/\/schema.org\/", "name":"Matt Biscay", "@type":"Person", "email":"hello@skyminds.net", "sameAs":[ " https:\/\/twitter.com\/skyminds", "https:\/\/www.skyminds.net\/", "https:\/\/www.facebook.com\/skyminds", "https:\/\/plus.google.com\/+SkymindsNet\/", "https:\/\/www.facebook.com\/matt.biscay" ] }</script>
<!--[if lt IE 9]><script src="//www.skyminds.net/wp-content/cache/wpfc-minified/822e4eab4b8769bc1e2a20f5c3555d0b/1499113378index.js' defer" type="text/javascript"></script><![endif]-->
<script>document.documentElement.className='js';</script>
<script>ref=escape(document[ 'referrer' ]);document.write("<input type='hidden' name='ref' value='"+ref+"'>");</script>
<script>r3f5x9JS=escape(document['referrer']);
hf1N='ed07b1aff165dae973079f29242fac5c';
hf1V='0e7f474d77b5570e485c03ec3a48e371';
document.write("<input type='hidden' name='r3f5x9JS' value='"+r3f5x9JS+"' /><input type='hidden' name='"+hf1N+"' value='"+hf1V+"' />");</script>
<script>window.__bp_session_timeout='900';
window.__bp_session_freezing=0;
!function(){window.bizpanda||(window.bizpanda={}),window.bizpanda.bp_can_store_localy=function(){return!1},window.bizpanda.bp_ut_get_cookie=function(e){for(var n=e+"=",i=document.cookie.split(";"),o=0;o<i.length;o++){for(var t=i[o];" "==t.charAt(0);)t=t.substring(1);if(0==t.indexOf(n))return decodeURIComponent(t.substring(n.length,t.length))}return!1},window.bizpanda.bp_ut_set_cookie=function(e,n,i){var o=new Date;o.setTime(o.getTime()+24*i*60*60*1e3);var t="expires="+o.toUTCString();document.cookie=e+"="+encodeURIComponent(n)+"; "+t+"; path=/"},window.bizpanda.bp_ut_get_obj=function(e){var n=null;return(n=window.bizpanda.bp_can_store_localy()?window.localStorage.getItem("bp_ut_session"):window.bizpanda.bp_ut_get_cookie("bp_ut_session"))?(n=n.replace(/\-c\-/g,","),n=n.replace(/\-q\-/g,'"'),n=JSON.parse(n),n.started+1e3*e<(new Date).getTime()&&(n=null),n):!1},window.bizpanda.bp_ut_set_obj=function(e,n){e.started&&window.__bp_session_freezing||(e.started=(new Date).getTime());var e=JSON.stringify(e);e&&(e=e.replace(/\"/g,"-q-"),e=e.replace(/\,/g,"-c-")),window.bizpanda.bp_can_store_localy()?window.localStorage.setItem("bp_ut_session",e):window.bizpanda.bp_ut_set_cookie("bp_ut_session",e,5e3)},window.bizpanda.bp_ut_count_pageview=function(){var e=window.bizpanda.bp_ut_get_obj(window.__bp_session_timeout);e||(e={}),e.pageviews||(e.pageviews=0),0===e.pageviews&&(e.referrer=document.referrer,e.landingPage=window.location.href,e.pageviews=0),e.pageviews++,window.bizpanda.bp_ut_set_obj(e)},window.bizpanda.bp_ut_count_locker_pageview=function(){var e=window.bizpanda.bp_ut_get_obj(window.__bp_timeout);e||(e={}),e.lockerPageviews||(e.lockerPageviews=0),e.lockerPageviews++,window.bizpanda.bp_ut_set_obj(e)},window.bizpanda.bp_ut_count_pageview()}();</script>
<script>r3f5x9JS=escape(document['referrer']);
hf4N='ed07b1aff165dae973079f29242fac5c';
hf4V='0e7f474d77b5570e485c03ec3a48e371';
cm4S="form[action='https://www.skyminds.net/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});});</script>
<script src='//www.skyminds.net/wp-content/cache/wpfc-minified/79909478e88aa0fb09f1fa0758961aab/1499113422index.js' type="text/javascript"></script>
<script>COOKIES_ENABLER.init({
scriptClass: 'ginger-script',
iframeClass: 'ginger-iframe',
acceptClass: 'ginger-accept',
disableClass: 'ginger-disable',
dismissClass: 'ginger-dismiss',
bannerClass: 'ginger_banner-wrapper',
bannerHTML:
document.getElementById('ginger-banner-html')!==null ?
document.getElementById('ginger-banner-html').innerHTML :
'<div class="ginger_banner bottom dialog light ginger_container ginger_container--open">'
+'<p class="ginger_message">'
+'Ce site utilise des cookies.'
+''
+'<a href="#" class="ginger_btn ginger-accept ginger_btn_accept_all">'
+ 'J\'accepte'
+'<\/a>'
+'<\/div>',
cookieDuration: 365,
eventScroll: true,
scrollOffset: 20,
clickOutside: true,
cookieName: 'ginger-cookie',
forceReload: true,
iframesPlaceholder: true,
iframesPlaceholderClass: 'ginger-iframe-placeholder',
iframesPlaceholderHTML:
document.getElementById('ginger-iframePlaceholder-html')!==null ?
document.getElementById('ginger-iframePlaceholder-html').innerHTML :
'<p>Ce site utilise des cookies.'
+'<a href="#" class="ginger_btn ginger-accept">J\'accepte'
+'<\/p>'
});</script>
<script defer type="text/javascript" src="https://stats.wp.com/e-201727.js" async defer></script>
<script>_stq=window._stq||[];
_stq.push([ 'view', {v:'ext',j:'1:5.1',blog:'42213611',post:'28709',tz:'2',srv:'www.skyminds.net'} ]);
_stq.push([ 'clickTrackerInit', '42213611', '28709' ]);</script>
<script>document.onreadystatechange=function(){if(document.readyState=="complete"){Prism.highlightAll()}};</script>
</body></html><!-- WP Fastest Cache file was created in 1.109757900238 seconds, on 07-07-17 11:47:20 --><!-- via php -->